Code UO16B - what to do

Anything not covered by the others forums post here!
karutto
Posts: 6
Joined: Fri May 19, 2017 11:29 pm

Code UO16B - what to do

Postby karutto » Fri May 19, 2017 11:36 pm

Hello,
My 12V battery ran dead and the check engine light came on. I cleared them after installing a new battery but code UO16B is still on. "Lost communication to ac compressor control module" and as expected the AC does not work. I checked all fuses. Now I understand that there could be a lose connection in the wire harness going to the AC unit but I already wiggled those. Since this happened exactly when the computer got confused due to the low 12V battery I am convinced it is a computer problem. Is there any way to reset it and to recognize the AC unit? The dealer said it would be very expensive to fix and I am convinced that there is nothing wrong mechanically. Advice much appreciated. Thank you.

2012 Volt

leppard3
Posts: 51
Joined: Thu Apr 09, 2015 6:26 pm

Re: Code UO16B - what to do

Postby leppard3 » Sat May 20, 2017 4:52 pm

Here is something I found:
when a U-code names a module. That U-code also doesn’t necessarily mean that the non-communicative module is defective – just that it isn’t talking. It could have lost power, ground or a communication line, and we’ve even heard of a U-code traced to a poor battery ground from a ground strap that was not making acceptable contact at its body connection.

If it were me, my first step would be disconnect the negative cable on the new battery for 10 to 15 minutes. Make sure the cable is well grounded. Maybe disconnecting it will reset the module???? I know it "should" have reset while you changed out the old to the new batteyr, but 12 volt systems can be strange.

If that does not work, I'm sorry, but I don't have any other ideas. Let us know what you find out.

karutto
Posts: 6
Joined: Fri May 19, 2017 11:29 pm

Re: Code UO16B - what to do

Postby karutto » Sat May 20, 2017 10:52 pm

Hi and thanks for your suggestion. I could try that again. But the old battery was removed for about 1 1/2 hours while I shopped for the new one but I'll try that again. thanks again.

leppard3
Posts: 51
Joined: Thu Apr 09, 2015 6:26 pm

Re: Code UO16B - what to do

Postby leppard3 » Sun May 21, 2017 7:09 am

Did you see the response over on your post at gm-volt.com? The guy asked if you had anything plugged in the OBD port, if so remove that.
I found that to be very interesting. Just a few days ago I plugged in one of those bluetooth OBD devices to monitor with mygreenvolt app. I parked my car in the garage, plugged in the device and went in my house. The next time I came out to drive my car, the doors were locked. I NEVER lock my doors in the garage, I thought that was really strange. Then when I started my car, the center stack screen was on the Navigation Map. I know for a 100% fact it was not on that screen when I shut down the car. Also 100% positve nobody else drove or had access to the car. Needless to say, I removed the OBD device never to be used again.

karutto
Posts: 6
Joined: Fri May 19, 2017 11:29 pm

Re: Code UO16B - what to do

Postby karutto » Sun May 21, 2017 1:28 pm

Nothing plugged in. Interestingly, I did have 2 cheap ass Ebay OBD readers plugged in to get the codes. Thank you

karutto
Posts: 6
Joined: Fri May 19, 2017 11:29 pm

Re: Code UO16B - what to do

Postby karutto » Mon May 22, 2017 4:55 pm

Okay so I disconnected the 12 full battery overnight, Hooked it back up and there was hope for a moment. No check engine light on and the remote start(climate control) worked (probably without AC). Shortly thereafter the check engine light was on again and no AC. Bummer!

So is this the way of the future? Where in the age of computerized cars car owners have to take their car to the dealer? And the dealers are laughing all the way to the bank?

But I don't even understand what the dealer would do. They couldn't possibly know. They must have some manuals or some way of getting help with this. And whatever they do, or consult, can I do that also?

Lastly, I remember I tried to jumpstart my vehicle with a lithium ion battery pack and it didn't work and the pack broke down. Is there any other place where fuses possibly are except the engine compartment and the trunk? Is there any other fuse that is somewhere hidden which could have possibly popped? Thanks again everyone

leppard3
Posts: 51
Joined: Thu Apr 09, 2015 6:26 pm

Re: Code UO16B - what to do

Postby leppard3 » Mon May 22, 2017 8:01 pm

Im not sure you said what model year your is, but I have a 2011 and here is a link to the manual. Im pretty sure you looked through a manual already, but the fuse locations are listed starting at section 10-33
https://my.chevrolet.com/content/dam/gm ... _owers.pdf

I also have a link to a more detailed tech manual, but I wasn't able to find anything there. Even if you don't find anything, it's a pretty detailed manual for future reference
http://www.autocats.ws/manual/chevrolet ... _Volt.html

karutto
Posts: 6
Joined: Fri May 19, 2017 11:29 pm

Re: Code UO16B - what to do

Postby karutto » Wed May 24, 2017 8:52 am

i checked all fuses. no avail

karutto
Posts: 6
Joined: Fri May 19, 2017 11:29 pm

Re: Code UO16B - what to do

Postby karutto » Fri May 26, 2017 12:03 am

nothing. wow! I have never experienced an automotive bind like this.


Return to “General Chevy Volt Forum”

Who is online

Users browsing this forum: No registered users and 3 guests